busybox.spec 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. %define name busybox
  2. %define epoch 0
  3. %define version 0.61.pre
  4. %define release %(date -I | sed -e 's/-/_/g')
  5. %define serial 1
  6. Name: %{name}
  7. #Epoch: %{epoch}
  8. Version: %{version}
  9. Release: %{release}
  10. Serial: %{serial}
  11. Copyright: GPL
  12. Group: System/Utilities
  13. Summary: BusyBox is a tiny suite of Unix utilities in a multi-call binary.
  14. URL: http://busybox.net/
  15. Source: ftp://busybox.net/busybox/%{name}-%{version}.tar.gz
  16. Buildroot: /var/tmp/%{name}-%{version}
  17. Packager : Erik Andersen <andersen@codepoet.org>
  18. %Description
  19. BusyBox combines tiny versions of many common UNIX utilities into a single
  20. small executable. It provides minimalist replacements for most of the utilities
  21. you usually find in fileutils, shellutils, findutils, textutils, grep, gzip,
  22. tar, etc. BusyBox provides a fairly complete POSIX environment for any small
  23. or emdedded system. The utilities in BusyBox generally have fewer options then
  24. their full featured GNU cousins; however, the options that are provided behave
  25. very much like their GNU counterparts.
  26. %Prep
  27. %setup -q -n %{name}-%{version}
  28. %Build
  29. make
  30. %Install
  31. rm -rf $RPM_BUILD_ROOT
  32. make CONFIG_PREFIX=$RPM_BUILD_ROOT install
  33. %Clean
  34. rm -rf $RPM_BUILD_ROOT
  35. %Files
  36. %defattr(-,root,root)
  37. /