APKBUILD 1.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # Contributor: Jakub Jirutka <jakub@jirutka.cz>
  2. # Contributor: xrs <xrs@mail36.net>
  3. # Maintainer: xrs <xrs@mail36.net>
  4. pkgname=gnurl
  5. pkgver=7.66.0
  6. pkgrel=0
  7. pkgdesc="curl with only HTTP/HTTPS support and GnuTLS"
  8. url="https://gnunet.org/en/gnurl.html"
  9. arch="all"
  10. license="MIT"
  11. depends="ca-certificates"
  12. depends_dev="gnutls-dev libidn2-dev zlib-dev"
  13. makedepends="$depends_dev autoconf automake libtool perl pkgconf python3"
  14. subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc libgnurl"
  15. source="https://ftp.gnu.org/gnu/gnunet/gnurl-$pkgver.tar.gz"
  16. prepare() {
  17. default_prepare
  18. autoreconf -vfi
  19. }
  20. build() {
  21. ./configure \
  22. --build=$CBUILD \
  23. --host=$CHOST \
  24. --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt \
  25. --prefix=/usr \
  26. --disable-static \
  27. --enable-ipv6 \
  28. --with-gnutls \
  29. --with-libidn2 \
  30. --without-libpsl \
  31. --without-libssh2 \
  32. --without-libmetalink \
  33. --without-winidn \
  34. --without-librtmp \
  35. --without-nghttp2 \
  36. --without-nss \
  37. --without-cyassl \
  38. --without-polarssl \
  39. --without-ssl \
  40. --without-winssl \
  41. --without-darwinssl \
  42. --disable-sspi \
  43. --disable-ldap \
  44. --disable-rtsp \
  45. --disable-dict \
  46. --disable-telnet \
  47. --disable-tftp \
  48. --disable-pop3 \
  49. --disable-imap \
  50. --disable-smtp \
  51. --disable-gopher \
  52. --disable-file \
  53. --disable-ftp \
  54. --disable-smb \
  55. --disable-ntlm-wb \
  56. --with-libz \
  57. --without-ca-fallback \
  58. --without-gssapi \
  59. --disable-valgrind \
  60. --without-ngtcp2 \
  61. --without-nghttp2 \
  62. --without-nghttp3 \
  63. --without-quiche
  64. make
  65. }
  66. check() {
  67. make -C tests nonflaky-test
  68. }
  69. package() {
  70. make DESTDIR="$pkgdir" install
  71. }
  72. libgnurl() {
  73. pkgdesc="curl library with only HTTP/HTTPS support and GnuTLS"
  74. mkdir -p "$subpkgdir"/usr
  75. mv "$pkgdir"/usr/lib "$subpkgdir"/usr
  76. }
  77. sha512sums="ab7305433b204ce68d139898efa1a74351a73c5e5bde121bb5ce1aa76f31cd07b699c18988a78f756262f9d7566b323651012ed0790bce15ed3e77aeba2c6dd9 gnurl-7.66.0.tar.gz"