openssl.spec 7.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. %define _unpackaged_files_terminate_build 0
  2. Release: 1
  3. %define openssldir /var/ssl
  4. Summary: Secure Sockets Layer and cryptography libraries and tools
  5. Name: openssl
  6. Version: 1.1.0
  7. #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
  8. Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
  9. License: OpenSSL
  10. Group: System Environment/Libraries
  11. Provides: SSL
  12. URL: http://www.openssl.org/
  13. Packager: Damien Miller <djm@mindrot.org>
  14. BuildRoot: /var/tmp/%{name}-%{version}-root
  15. %description
  16. The OpenSSL Project is a collaborative effort to develop a robust,
  17. commercial-grade, fully featured, and Open Source toolkit implementing the
  18. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  19. protocols as well as a full-strength general purpose cryptography library.
  20. The project is managed by a worldwide community of volunteers that use the
  21. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  22. documentation.
  23. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  24. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  25. Apache-style licence, which basically means that you are free to get and
  26. use it for commercial and non-commercial purposes.
  27. This package contains the base OpenSSL cryptography and SSL/TLS
  28. libraries and tools.
  29. %package devel
  30. Summary: Secure Sockets Layer and cryptography static libraries and headers
  31. Group: Development/Libraries
  32. Requires: openssl
  33. %description devel
  34. The OpenSSL Project is a collaborative effort to develop a robust,
  35. commercial-grade, fully featured, and Open Source toolkit implementing the
  36. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  37. protocols as well as a full-strength general purpose cryptography library.
  38. The project is managed by a worldwide community of volunteers that use the
  39. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  40. documentation.
  41. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  42. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  43. Apache-style licence, which basically means that you are free to get and
  44. use it for commercial and non-commercial purposes.
  45. This package contains the the OpenSSL cryptography and SSL/TLS
  46. static libraries and header files required when developing applications.
  47. %package doc
  48. Summary: OpenSSL miscellaneous files
  49. Group: Documentation
  50. Requires: openssl
  51. %description doc
  52. The OpenSSL Project is a collaborative effort to develop a robust,
  53. commercial-grade, fully featured, and Open Source toolkit implementing the
  54. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  55. protocols as well as a full-strength general purpose cryptography library.
  56. The project is managed by a worldwide community of volunteers that use the
  57. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  58. documentation.
  59. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  60. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  61. Apache-style licence, which basically means that you are free to get and
  62. use it for commercial and non-commercial purposes.
  63. This package contains the the OpenSSL cryptography and SSL/TLS extra
  64. documentation and POD files from which the man pages were produced.
  65. %prep
  66. %setup -q
  67. %build
  68. %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
  69. perl util/perlpath.pl /usr/bin/perl
  70. %ifarch i386 i486 i586 i686
  71. ./Configure %{CONFIG_FLAGS} linux-elf shared
  72. %endif
  73. %ifarch ppc
  74. ./Configure %{CONFIG_FLAGS} linux-ppc shared
  75. %endif
  76. %ifarch alpha
  77. ./Configure %{CONFIG_FLAGS} linux-alpha shared
  78. %endif
  79. %ifarch x86_64
  80. ./Configure %{CONFIG_FLAGS} linux-x86_64 shared
  81. %endif
  82. LD_LIBRARY_PATH=`pwd` make
  83. LD_LIBRARY_PATH=`pwd` make rehash
  84. LD_LIBRARY_PATH=`pwd` make test
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
  88. # Make backwards-compatibility symlink to ssleay
  89. ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %files
  93. %defattr(0644,root,root,0755)
  94. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  95. %attr(0755,root,root) /usr/bin/*
  96. %attr(0755,root,root) /usr/lib/*.so*
  97. %attr(0755,root,root) %{openssldir}/misc/*
  98. %attr(0644,root,root) /usr/man/man[157]/*
  99. %config %attr(0644,root,root) %{openssldir}/openssl.cnf
  100. %dir %attr(0755,root,root) %{openssldir}/certs
  101. %dir %attr(0755,root,root) %{openssldir}/misc
  102. %dir %attr(0750,root,root) %{openssldir}/private
  103. %files devel
  104. %defattr(0644,root,root,0755)
  105. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  106. %attr(0644,root,root) /usr/lib/*.a
  107. %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
  108. %attr(0644,root,root) /usr/include/openssl/*
  109. %attr(0644,root,root) /usr/man/man[3]/*
  110. %files doc
  111. %defattr(0644,root,root,0755)
  112. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  113. %doc doc
  114. %post
  115. ldconfig
  116. %postun
  117. ldconfig
  118. %changelog
  119. * Sun Jun 6 2005 Richard Levitte <richard@levitte.org>
  120. - Remove the incorrect installation of '%{openssldir}/lib'.
  121. * Wed May 7 2003 Richard Levitte <richard@levitte.org>
  122. - Add /usr/lib/pkgconfig/openssl.pc to the development section.
  123. * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
  124. - Removed redundant subsection that re-installed libcrypto.a and libssl.a
  125. as well. Also remove RSAref stuff completely, since it's not needed
  126. any more.
  127. * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
  128. - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
  129. libssl.so.0.9.6. As well as the subsection that created symlinks for
  130. these. make install handles all this.
  131. * Sat Oct 21 2000 Horms <horms@vergenet.net>
  132. - Make sure symlinks are created by using -f flag to ln.
  133. Otherwise some .so libraries are copied rather than
  134. linked in the resulting binary RPM. This causes the package
  135. to be larger than necessary and makes ldconfig complain.
  136. * Fri Oct 13 2000 Horms <horms@vergenet.net>
  137. - Make defattr is set for files in all packages so packages built as
  138. non-root will still be installed with files owned by root.
  139. * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
  140. - Changed to adapt to the new (supported) way of making shared libraries
  141. - Installs all static libraries, not just libRSAglue.a
  142. - Extra documents now end up in a separate document package
  143. * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
  144. - Merged patches to spec
  145. - Updated to 0.9.5beta2 (now with manpages)
  146. * Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
  147. - added 'linux-alpha' to configuration
  148. - fixed nasty absolute links
  149. * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
  150. - Added -DSSL_ALLOW_ADH, bumped Release to 4
  151. * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
  152. - Set default permissions
  153. - Removed documentation from devel sub-package
  154. * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
  155. - Added "make test" stage
  156. - GPG signed
  157. * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
  158. - Updated to version 0.9.4
  159. * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
  160. - Updated to version 0.9.3
  161. - Added attributes for all files
  162. - Paramatised openssl directory
  163. * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
  164. - Added "official" bnrec patch and taking other out
  165. - making a link from ssleay to openssl binary
  166. - putting all changelog together on SPEC file
  167. * Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
  168. - Added bnrec patch
  169. * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
  170. - minimum spec and patches changes for openssl
  171. - modified for openssl sources
  172. * Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
  173. - shared library creating process honours $RPM_OPT_FLAGS
  174. - shared libarry supports threads (as well as static library)
  175. * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
  176. - building of shared library completely reworked
  177. * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
  178. - RPM is BuildRoot'ed
  179. * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
  180. - all stuff is moved out of /usr/local