openssl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209
  1. %define _unpackaged_files_terminate_build 0
  2. Release: 1
  3. %define openssldir /var/ssl
  4. Summary: Secure Sockets Layer and cryptography libraries and tools
  5. Name: openssl
  6. Version: 0.9.8zg
  7. Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
  8. License: OpenSSL
  9. Group: System Environment/Libraries
  10. Provides: SSL
  11. URL: http://www.openssl.org/
  12. Packager: Damien Miller <djm@mindrot.org>
  13. BuildRoot: /var/tmp/%{name}-%{version}-root
  14. %description
  15. The OpenSSL Project is a collaborative effort to develop a robust,
  16. commercial-grade, fully featured, and Open Source toolkit implementing the
  17. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  18. protocols as well as a full-strength general purpose cryptography library.
  19. The project is managed by a worldwide community of volunteers that use the
  20. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  21. documentation.
  22. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  23. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  24. Apache-style licence, which basically means that you are free to get and
  25. use it for commercial and non-commercial purposes.
  26. This package contains the base OpenSSL cryptography and SSL/TLS
  27. libraries and tools.
  28. %package devel
  29. Summary: Secure Sockets Layer and cryptography static libraries and headers
  30. Group: Development/Libraries
  31. Requires: openssl
  32. %description devel
  33. The OpenSSL Project is a collaborative effort to develop a robust,
  34. commercial-grade, fully featured, and Open Source toolkit implementing the
  35. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  36. protocols as well as a full-strength general purpose cryptography library.
  37. The project is managed by a worldwide community of volunteers that use the
  38. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  39. documentation.
  40. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  41. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  42. Apache-style licence, which basically means that you are free to get and
  43. use it for commercial and non-commercial purposes.
  44. This package contains the the OpenSSL cryptography and SSL/TLS
  45. static libraries and header files required when developing applications.
  46. %package doc
  47. Summary: OpenSSL miscellaneous files
  48. Group: Documentation
  49. Requires: openssl
  50. %description doc
  51. The OpenSSL Project is a collaborative effort to develop a robust,
  52. commercial-grade, fully featured, and Open Source toolkit implementing the
  53. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  54. protocols as well as a full-strength general purpose cryptography library.
  55. The project is managed by a worldwide community of volunteers that use the
  56. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  57. documentation.
  58. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  59. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  60. Apache-style licence, which basically means that you are free to get and
  61. use it for commercial and non-commercial purposes.
  62. This package contains the the OpenSSL cryptography and SSL/TLS extra
  63. documentation and POD files from which the man pages were produced.
  64. %prep
  65. %setup -q
  66. %build
  67. %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
  68. perl util/perlpath.pl /usr/bin/perl
  69. %ifarch i386 i486 i586 i686
  70. ./Configure %{CONFIG_FLAGS} linux-elf shared
  71. %endif
  72. %ifarch ppc
  73. ./Configure %{CONFIG_FLAGS} linux-ppc shared
  74. %endif
  75. %ifarch alpha
  76. ./Configure %{CONFIG_FLAGS} linux-alpha shared
  77. %endif
  78. %ifarch x86_64
  79. ./Configure %{CONFIG_FLAGS} linux-x86_64 shared
  80. %endif
  81. LD_LIBRARY_PATH=`pwd` make
  82. LD_LIBRARY_PATH=`pwd` make rehash
  83. LD_LIBRARY_PATH=`pwd` make test
  84. %install
  85. rm -rf $RPM_BUILD_ROOT
  86. make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
  87. # Make backwards-compatibility symlink to ssleay
  88. ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %files
  92. %defattr(0644,root,root,0755)
  93. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  94. %attr(0755,root,root) /usr/bin/*
  95. %attr(0755,root,root) /usr/lib/*.so*
  96. %attr(0755,root,root) %{openssldir}/misc/*
  97. %attr(0644,root,root) /usr/man/man[157]/*
  98. %config %attr(0644,root,root) %{openssldir}/openssl.cnf
  99. %dir %attr(0755,root,root) %{openssldir}/certs
  100. %dir %attr(0755,root,root) %{openssldir}/misc
  101. %dir %attr(0750,root,root) %{openssldir}/private
  102. %files devel
  103. %defattr(0644,root,root,0755)
  104. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  105. %attr(0644,root,root) /usr/lib/*.a
  106. %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
  107. %attr(0644,root,root) /usr/include/openssl/*
  108. %attr(0644,root,root) /usr/man/man[3]/*
  109. %files doc
  110. %defattr(0644,root,root,0755)
  111. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  112. %doc doc
  113. %post
  114. ldconfig
  115. %postun
  116. ldconfig
  117. %changelog
  118. * Sun Jun 6 2005 Richard Levitte <richard@levitte.org>
  119. - Remove the incorrect installation of '%{openssldir}/lib'.
  120. * Wed May 7 2003 Richard Levitte <richard@levitte.org>
  121. - Add /usr/lib/pkgconfig/openssl.pc to the development section.
  122. * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
  123. - Removed redundant subsection that re-installed libcrypto.a and libssl.a
  124. as well. Also remove RSAref stuff completely, since it's not needed
  125. any more.
  126. * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
  127. - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
  128. libssl.so.0.9.6. As well as the subsection that created symlinks for
  129. these. make install handles all this.
  130. * Sat Oct 21 2000 Horms <horms@vergenet.net>
  131. - Make sure symlinks are created by using -f flag to ln.
  132. Otherwise some .so libraries are copied rather than
  133. linked in the resulting binary RPM. This causes the package
  134. to be larger than neccessary and makes ldconfig complain.
  135. * Fri Oct 13 2000 Horms <horms@vergenet.net>
  136. - Make defattr is set for files in all packages so packages built as
  137. non-root will still be installed with files owned by root.
  138. * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
  139. - Changed to adapt to the new (supported) way of making shared libraries
  140. - Installs all static libraries, not just libRSAglue.a
  141. - Extra documents now end up in a separate document package
  142. * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
  143. - Merged patches to spec
  144. - Updated to 0.9.5beta2 (now with manpages)
  145. * Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
  146. - added 'linux-alpha' to configuration
  147. - fixed nasty absolute links
  148. * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
  149. - Added -DSSL_ALLOW_ADH, bumped Release to 4
  150. * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
  151. - Set default permissions
  152. - Removed documentation from devel sub-package
  153. * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
  154. - Added "make test" stage
  155. - GPG signed
  156. * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
  157. - Updated to version 0.9.4
  158. * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
  159. - Updated to version 0.9.3
  160. - Added attributes for all files
  161. - Paramatised openssl directory
  162. * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
  163. - Added "official" bnrec patch and taking other out
  164. - making a link from ssleay to openssl binary
  165. - putting all changelog together on SPEC file
  166. * Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
  167. - Added bnrec patch
  168. * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
  169. - minimum spec and patches changes for openssl
  170. - modified for openssl sources
  171. * Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
  172. - shared library creating process honours $RPM_OPT_FLAGS
  173. - shared libarry supports threads (as well as static library)
  174. * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
  175. - building of shared library completely reworked
  176. * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
  177. - RPM is BuildRoot'ed
  178. * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
  179. - all stuff is moved out of /usr/local