openssl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210
  1. %define libmaj 0
  2. %define libmin 9
  3. %define librel 8
  4. #%define librev a
  5. Release: 1
  6. %define openssldir /var/ssl
  7. Summary: Secure Sockets Layer and cryptography libraries and tools
  8. Name: openssl
  9. Version: %{libmaj}.%{libmin}.%{librel}
  10. #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
  11. Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
  12. Copyright: Freely distributable
  13. Group: System Environment/Libraries
  14. Provides: SSL
  15. URL: http://www.openssl.org/
  16. Packager: Damien Miller <djm@mindrot.org>
  17. BuildRoot: /var/tmp/%{name}-%{version}-root
  18. %description
  19. The OpenSSL Project is a collaborative effort to develop a robust,
  20. commercial-grade, fully featured, and Open Source toolkit implementing the
  21. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  22. protocols as well as a full-strength general purpose cryptography library.
  23. The project is managed by a worldwide community of volunteers that use the
  24. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  25. documentation.
  26. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  27. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  28. Apache-style licence, which basically means that you are free to get and
  29. use it for commercial and non-commercial purposes.
  30. This package contains the base OpenSSL cryptography and SSL/TLS
  31. libraries and tools.
  32. %package devel
  33. Summary: Secure Sockets Layer and cryptography static libraries and headers
  34. Group: Development/Libraries
  35. Requires: openssl
  36. %description devel
  37. The OpenSSL Project is a collaborative effort to develop a robust,
  38. commercial-grade, fully featured, and Open Source toolkit implementing the
  39. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  40. protocols as well as a full-strength general purpose cryptography library.
  41. The project is managed by a worldwide community of volunteers that use the
  42. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  43. documentation.
  44. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  45. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  46. Apache-style licence, which basically means that you are free to get and
  47. use it for commercial and non-commercial purposes.
  48. This package contains the the OpenSSL cryptography and SSL/TLS
  49. static libraries and header files required when developing applications.
  50. %package doc
  51. Summary: OpenSSL miscellaneous files
  52. Group: Documentation
  53. Requires: openssl
  54. %description doc
  55. The OpenSSL Project is a collaborative effort to develop a robust,
  56. commercial-grade, fully featured, and Open Source toolkit implementing the
  57. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  58. protocols as well as a full-strength general purpose cryptography library.
  59. The project is managed by a worldwide community of volunteers that use the
  60. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  61. documentation.
  62. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  63. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  64. Apache-style licence, which basically means that you are free to get and
  65. use it for commercial and non-commercial purposes.
  66. This package contains the the OpenSSL cryptography and SSL/TLS extra
  67. documentation and POD files from which the man pages were produced.
  68. %prep
  69. %setup -q
  70. %build
  71. %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr
  72. perl util/perlpath.pl /usr/bin/perl
  73. %ifarch i386 i486 i586 i686
  74. ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-elf shared
  75. %endif
  76. %ifarch ppc
  77. ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-ppc shared
  78. %endif
  79. %ifarch alpha
  80. ./Configure %{CONFIG_FLAGS} --openssldir=%{openssldir} linux-alpha shared
  81. %endif
  82. LD_LIBRARY_PATH=`pwd` make
  83. LD_LIBRARY_PATH=`pwd` make rehash
  84. LD_LIBRARY_PATH=`pwd` make test
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. make MANDIR=/usr/man INSTALL_PREFIX="$RPM_BUILD_ROOT" install
  88. # Rename manpages
  89. for x in $RPM_BUILD_ROOT/usr/man/man*/*
  90. do mv ${x} ${x}ssl
  91. done
  92. # Make backwards-compatibility symlink to ssleay
  93. ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %files
  97. %defattr(0644,root,root,0755)
  98. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  99. %attr(0755,root,root) /usr/bin/*
  100. %attr(0755,root,root) /usr/lib/*.so*
  101. %attr(0755,root,root) %{openssldir}/misc/*
  102. %attr(0644,root,root) /usr/man/man[157]/*
  103. %config %attr(0644,root,root) %{openssldir}/openssl.cnf
  104. %dir %attr(0755,root,root) %{openssldir}/certs
  105. %dir %attr(0755,root,root) %{openssldir}/lib
  106. %dir %attr(0755,root,root) %{openssldir}/misc
  107. %dir %attr(0750,root,root) %{openssldir}/private
  108. %files devel
  109. %defattr(0644,root,root,0755)
  110. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  111. %attr(0644,root,root) /usr/lib/*.a
  112. %attr(0644,root,root) /usr/include/openssl/*
  113. %attr(0644,root,root) /usr/man/man[3]/*
  114. %files doc
  115. %defattr(0644,root,root,0755)
  116. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  117. %doc doc
  118. %post
  119. ldconfig
  120. %postun
  121. ldconfig
  122. %changelog
  123. * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
  124. - Removed redundant subsection that re-installed libcrypto.a and libssl.a
  125. as well. Also remove RSAref stuff completely, since it's not needed
  126. any more.
  127. * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
  128. - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
  129. libssl.so.0.9.6. As well as the subsection that created symlinks for
  130. these. make install handles all this.
  131. * Sat Oct 21 2000 Horms <horms@vergenet.net>
  132. - Make sure symlinks are created by using -f flag to ln.
  133. Otherwise some .so libraries are copied rather than
  134. linked in the resulting binary RPM. This causes the package
  135. to be larger than neccessary and makes ldconfig complain.
  136. * Fri Oct 13 2000 Horms <horms@vergenet.net>
  137. - Make defattr is set for files in all packages so packages built as
  138. non-root will still be installed with files owned by root.
  139. * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
  140. - Changed to adapt to the new (supported) way of making shared libraries
  141. - Installs all static libraries, not just libRSAglue.a
  142. - Extra documents now end up in a separate document package
  143. * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
  144. - Merged patches to spec
  145. - Updated to 0.9.5beta2 (now with manpages)
  146. * Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
  147. - added 'linux-alpha' to configuration
  148. - fixed nasty absolute links
  149. * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
  150. - Added -DSSL_ALLOW_ADH, bumped Release to 4
  151. * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
  152. - Set default permissions
  153. - Removed documentation from devel sub-package
  154. * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
  155. - Added "make test" stage
  156. - GPG signed
  157. * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
  158. - Updated to version 0.9.4
  159. * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
  160. - Updated to version 0.9.3
  161. - Added attributes for all files
  162. - Paramatised openssl directory
  163. * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
  164. - Added "official" bnrec patch and taking other out
  165. - making a link from ssleay to openssl binary
  166. - putting all changelog together on SPEC file
  167. * Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
  168. - Added bnrec patch
  169. * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
  170. - minimum spec and patches changes for openssl
  171. - modified for openssl sources
  172. * Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
  173. - shared library creating process honours $RPM_OPT_FLAGS
  174. - shared libarry supports threads (as well as static library)
  175. * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
  176. - building of shared library completely reworked
  177. * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
  178. - RPM is BuildRoot'ed
  179. * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
  180. - all stuff is moved out of /usr/local