openssl.spec 7.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. %define libmaj 0
  2. %define libmin 9
  3. %define librel 7
  4. %define librev d
  5. Release: 1
  6. %define openssldir /var/ssl
  7. Summary: Secure Sockets Layer and cryptography libraries and tools
  8. Name: openssl
  9. #Version: %{libmaj}.%{libmin}.%{librel}
  10. Version: %{libmaj}.%{libmin}.%{librel}%{librev}
  11. Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
  12. Copyright: Freely distributable
  13. Group: System Environment/Libraries
  14. Provides: SSL
  15. URL: http://www.openssl.org/
  16. Packager: Damien Miller <djm@mindrot.org>
  17. BuildRoot: /var/tmp/%{name}-%{version}-root
  18. %description
  19. The OpenSSL Project is a collaborative effort to develop a robust,
  20. commercial-grade, fully featured, and Open Source toolkit implementing the
  21. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  22. protocols as well as a full-strength general purpose cryptography library.
  23. The project is managed by a worldwide community of volunteers that use the
  24. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  25. documentation.
  26. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  27. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  28. Apache-style licence, which basically means that you are free to get and
  29. use it for commercial and non-commercial purposes.
  30. This package contains the base OpenSSL cryptography and SSL/TLS
  31. libraries and tools.
  32. %package devel
  33. Summary: Secure Sockets Layer and cryptography static libraries and headers
  34. Group: Development/Libraries
  35. Requires: openssl
  36. %description devel
  37. The OpenSSL Project is a collaborative effort to develop a robust,
  38. commercial-grade, fully featured, and Open Source toolkit implementing the
  39. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  40. protocols as well as a full-strength general purpose cryptography library.
  41. The project is managed by a worldwide community of volunteers that use the
  42. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  43. documentation.
  44. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  45. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  46. Apache-style licence, which basically means that you are free to get and
  47. use it for commercial and non-commercial purposes.
  48. This package contains the the OpenSSL cryptography and SSL/TLS
  49. static libraries and header files required when developing applications.
  50. %package doc
  51. Summary: OpenSSL miscellaneous files
  52. Group: Documentation
  53. Requires: openssl
  54. %description doc
  55. The OpenSSL Project is a collaborative effort to develop a robust,
  56. commercial-grade, fully featured, and Open Source toolkit implementing the
  57. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  58. protocols as well as a full-strength general purpose cryptography library.
  59. The project is managed by a worldwide community of volunteers that use the
  60. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  61. documentation.
  62. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  63. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  64. Apache-style licence, which basically means that you are free to get and
  65. use it for commercial and non-commercial purposes.
  66. This package contains the the OpenSSL cryptography and SSL/TLS extra
  67. documentation and POD files from which the man pages were produced.
  68. %prep
  69. %setup -q
  70. %build
  71. %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
  72. perl util/perlpath.pl /usr/bin/perl
  73. %ifarch i386 i486 i586 i686
  74. ./Configure %{CONFIG_FLAGS} linux-elf shared
  75. %endif
  76. %ifarch ppc
  77. ./Configure %{CONFIG_FLAGS} linux-ppc shared
  78. %endif
  79. %ifarch alpha
  80. ./Configure %{CONFIG_FLAGS} linux-alpha shared
  81. %endif
  82. LD_LIBRARY_PATH=`pwd` make
  83. LD_LIBRARY_PATH=`pwd` make rehash
  84. LD_LIBRARY_PATH=`pwd` make test
  85. %install
  86. rm -rf $RPM_BUILD_ROOT
  87. make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
  88. # Make backwards-compatibility symlink to ssleay
  89. ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %files
  93. %defattr(0644,root,root,0755)
  94. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  95. %attr(0755,root,root) /usr/bin/*
  96. %attr(0755,root,root) /usr/lib/*.so*
  97. %attr(0755,root,root) %{openssldir}/misc/*
  98. %attr(0644,root,root) /usr/man/man[157]/*
  99. %config %attr(0644,root,root) %{openssldir}/openssl.cnf
  100. %dir %attr(0755,root,root) %{openssldir}/certs
  101. %dir %attr(0755,root,root) %{openssldir}/lib
  102. %dir %attr(0755,root,root) %{openssldir}/misc
  103. %dir %attr(0750,root,root) %{openssldir}/private
  104. %files devel
  105. %defattr(0644,root,root,0755)
  106. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  107. %attr(0644,root,root) /usr/lib/*.a
  108. %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
  109. %attr(0644,root,root) /usr/include/openssl/*
  110. %attr(0644,root,root) /usr/man/man[3]/*
  111. %files doc
  112. %defattr(0644,root,root,0755)
  113. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  114. %doc doc
  115. %post
  116. ldconfig
  117. %postun
  118. ldconfig
  119. %changelog
  120. * Wed May 7 2003 Richard Levitte <richard@levitte.org>
  121. - Add /usr/lib/pkgconfig/openssl.pc to the development section.
  122. * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
  123. - Removed redundant subsection that re-installed libcrypto.a and libssl.a
  124. as well. Also remove RSAref stuff completely, since it's not needed
  125. any more.
  126. * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
  127. - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
  128. libssl.so.0.9.6. As well as the subsection that created symlinks for
  129. these. make install handles all this.
  130. * Sat Oct 21 2000 Horms <horms@vergenet.net>
  131. - Make sure symlinks are created by using -f flag to ln.
  132. Otherwise some .so libraries are copied rather than
  133. linked in the resulting binary RPM. This causes the package
  134. to be larger than neccessary and makes ldconfig complain.
  135. * Fri Oct 13 2000 Horms <horms@vergenet.net>
  136. - Make defattr is set for files in all packages so packages built as
  137. non-root will still be installed with files owned by root.
  138. * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
  139. - Changed to adapt to the new (supported) way of making shared libraries
  140. - Installs all static libraries, not just libRSAglue.a
  141. - Extra documents now end up in a separate document package
  142. * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
  143. - Merged patches to spec
  144. - Updated to 0.9.5beta2 (now with manpages)
  145. * Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
  146. - added 'linux-alpha' to configuration
  147. - fixed nasty absolute links
  148. * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
  149. - Added -DSSL_ALLOW_ADH, bumped Release to 4
  150. * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
  151. - Set default permissions
  152. - Removed documentation from devel sub-package
  153. * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
  154. - Added "make test" stage
  155. - GPG signed
  156. * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
  157. - Updated to version 0.9.4
  158. * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
  159. - Updated to version 0.9.3
  160. - Added attributes for all files
  161. - Paramatised openssl directory
  162. * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
  163. - Added "official" bnrec patch and taking other out
  164. - making a link from ssleay to openssl binary
  165. - putting all changelog together on SPEC file
  166. * Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
  167. - Added bnrec patch
  168. * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
  169. - minimum spec and patches changes for openssl
  170. - modified for openssl sources
  171. * Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
  172. - shared library creating process honours $RPM_OPT_FLAGS
  173. - shared libarry supports threads (as well as static library)
  174. * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
  175. - building of shared library completely reworked
  176. * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
  177. - RPM is BuildRoot'ed
  178. * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
  179. - all stuff is moved out of /usr/local