openssl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %define _unpackaged_files_terminate_build 0
  2. %define libmaj 1
  3. %define libmin 1
  4. %define librel 0
  5. #%define librev a
  6. Release: 1
  7. %define openssldir /var/ssl
  8. Summary: Secure Sockets Layer and cryptography libraries and tools
  9. Name: openssl
  10. Version: %{libmaj}.%{libmin}.%{librel}
  11. #Version: %{libmaj}.%{libmin}.%{librel}%{librev}
  12. Source0: ftp://ftp.openssl.org/source/%{name}-%{version}.tar.gz
  13. Copyright: Freely distributable
  14. Group: System Environment/Libraries
  15. Provides: SSL
  16. URL: http://www.openssl.org/
  17. Packager: Damien Miller <djm@mindrot.org>
  18. BuildRoot: /var/tmp/%{name}-%{version}-root
  19. %description
  20. The OpenSSL Project is a collaborative effort to develop a robust,
  21. commercial-grade, fully featured, and Open Source toolkit implementing the
  22. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  23. protocols as well as a full-strength general purpose cryptography library.
  24. The project is managed by a worldwide community of volunteers that use the
  25. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  26. documentation.
  27. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  28. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  29. Apache-style licence, which basically means that you are free to get and
  30. use it for commercial and non-commercial purposes.
  31. This package contains the base OpenSSL cryptography and SSL/TLS
  32. libraries and tools.
  33. %package devel
  34. Summary: Secure Sockets Layer and cryptography static libraries and headers
  35. Group: Development/Libraries
  36. Requires: openssl
  37. %description devel
  38. The OpenSSL Project is a collaborative effort to develop a robust,
  39. commercial-grade, fully featured, and Open Source toolkit implementing the
  40. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  41. protocols as well as a full-strength general purpose cryptography library.
  42. The project is managed by a worldwide community of volunteers that use the
  43. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  44. documentation.
  45. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  46. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  47. Apache-style licence, which basically means that you are free to get and
  48. use it for commercial and non-commercial purposes.
  49. This package contains the the OpenSSL cryptography and SSL/TLS
  50. static libraries and header files required when developing applications.
  51. %package doc
  52. Summary: OpenSSL miscellaneous files
  53. Group: Documentation
  54. Requires: openssl
  55. %description doc
  56. The OpenSSL Project is a collaborative effort to develop a robust,
  57. commercial-grade, fully featured, and Open Source toolkit implementing the
  58. Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
  59. protocols as well as a full-strength general purpose cryptography library.
  60. The project is managed by a worldwide community of volunteers that use the
  61. Internet to communicate, plan, and develop the OpenSSL tookit and its related
  62. documentation.
  63. OpenSSL is based on the excellent SSLeay library developed from Eric A.
  64. Young and Tim J. Hudson. The OpenSSL toolkit is licensed under an
  65. Apache-style licence, which basically means that you are free to get and
  66. use it for commercial and non-commercial purposes.
  67. This package contains the the OpenSSL cryptography and SSL/TLS extra
  68. documentation and POD files from which the man pages were produced.
  69. %prep
  70. %setup -q
  71. %build
  72. %define CONFIG_FLAGS -DSSL_ALLOW_ADH --prefix=/usr --openssldir=%{openssldir}
  73. perl util/perlpath.pl /usr/bin/perl
  74. %ifarch i386 i486 i586 i686
  75. ./Configure %{CONFIG_FLAGS} linux-elf shared
  76. %endif
  77. %ifarch ppc
  78. ./Configure %{CONFIG_FLAGS} linux-ppc shared
  79. %endif
  80. %ifarch alpha
  81. ./Configure %{CONFIG_FLAGS} linux-alpha shared
  82. %endif
  83. %ifarch x86_64
  84. ./Configure %{CONFIG_FLAGS} linux-x86_64 shared
  85. %endif
  86. LD_LIBRARY_PATH=`pwd` make
  87. LD_LIBRARY_PATH=`pwd` make rehash
  88. LD_LIBRARY_PATH=`pwd` make test
  89. %install
  90. rm -rf $RPM_BUILD_ROOT
  91. make MANDIR=/usr/man MANSUFFIX=ssl INSTALL_PREFIX="$RPM_BUILD_ROOT" install
  92. # Make backwards-compatibility symlink to ssleay
  93. ln -sf /usr/bin/openssl $RPM_BUILD_ROOT/usr/bin/ssleay
  94. %clean
  95. rm -rf $RPM_BUILD_ROOT
  96. %files
  97. %defattr(0644,root,root,0755)
  98. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  99. %attr(0755,root,root) /usr/bin/*
  100. %attr(0755,root,root) /usr/lib/*.so*
  101. %attr(0755,root,root) %{openssldir}/misc/*
  102. %attr(0644,root,root) /usr/man/man[157]/*
  103. %config %attr(0644,root,root) %{openssldir}/openssl.cnf
  104. %dir %attr(0755,root,root) %{openssldir}/certs
  105. %dir %attr(0755,root,root) %{openssldir}/misc
  106. %dir %attr(0750,root,root) %{openssldir}/private
  107. %files devel
  108. %defattr(0644,root,root,0755)
  109. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  110. %attr(0644,root,root) /usr/lib/*.a
  111. %attr(0644,root,root) /usr/lib/pkgconfig/openssl.pc
  112. %attr(0644,root,root) /usr/include/openssl/*
  113. %attr(0644,root,root) /usr/man/man[3]/*
  114. %files doc
  115. %defattr(0644,root,root,0755)
  116. %doc CHANGES CHANGES.SSLeay LICENSE NEWS README
  117. %doc doc
  118. %post
  119. ldconfig
  120. %postun
  121. ldconfig
  122. %changelog
  123. * Sun Jun 6 2005 Richard Levitte <richard@levitte.org>
  124. - Remove the incorrect installation of '%{openssldir}/lib'.
  125. * Wed May 7 2003 Richard Levitte <richard@levitte.org>
  126. - Add /usr/lib/pkgconfig/openssl.pc to the development section.
  127. * Thu Mar 22 2001 Richard Levitte <richard@levitte.org>
  128. - Removed redundant subsection that re-installed libcrypto.a and libssl.a
  129. as well. Also remove RSAref stuff completely, since it's not needed
  130. any more.
  131. * Thu Mar 15 2001 Jeremiah Johnson <jjohnson@penguincomputing.com>
  132. - Removed redundant subsection that re-installed libcrypto.so.0.9.6 and
  133. libssl.so.0.9.6. As well as the subsection that created symlinks for
  134. these. make install handles all this.
  135. * Sat Oct 21 2000 Horms <horms@vergenet.net>
  136. - Make sure symlinks are created by using -f flag to ln.
  137. Otherwise some .so libraries are copied rather than
  138. linked in the resulting binary RPM. This causes the package
  139. to be larger than neccessary and makes ldconfig complain.
  140. * Fri Oct 13 2000 Horms <horms@vergenet.net>
  141. - Make defattr is set for files in all packages so packages built as
  142. non-root will still be installed with files owned by root.
  143. * Thu Sep 14 2000 Richard Levitte <richard@levitte.org>
  144. - Changed to adapt to the new (supported) way of making shared libraries
  145. - Installs all static libraries, not just libRSAglue.a
  146. - Extra documents now end up in a separate document package
  147. * Sun Feb 27 2000 Damien Miller <djm@mindrot.org>
  148. - Merged patches to spec
  149. - Updated to 0.9.5beta2 (now with manpages)
  150. * Sat Feb 5 2000 Michal Jaegermann <michal@harddata.com>
  151. - added 'linux-alpha' to configuration
  152. - fixed nasty absolute links
  153. * Tue Jan 25 2000 Bennett Todd <bet@rahul.net>
  154. - Added -DSSL_ALLOW_ADH, bumped Release to 4
  155. * Thu Oct 14 1999 Damien Miller <djm@mindrot.org>
  156. - Set default permissions
  157. - Removed documentation from devel sub-package
  158. * Thu Sep 30 1999 Damien Miller <djm@mindrot.org>
  159. - Added "make test" stage
  160. - GPG signed
  161. * Tue Sep 10 1999 Damien Miller <damien@ibs.com.au>
  162. - Updated to version 0.9.4
  163. * Tue May 25 1999 Damien Miller <damien@ibs.com.au>
  164. - Updated to version 0.9.3
  165. - Added attributes for all files
  166. - Paramatised openssl directory
  167. * Sat Mar 20 1999 Carlo M. Arenas Belon <carenas@jmconsultores.com.pe>
  168. - Added "official" bnrec patch and taking other out
  169. - making a link from ssleay to openssl binary
  170. - putting all changelog together on SPEC file
  171. * Fri Mar 5 1999 Henri Gomez <gomez@slib.fr>
  172. - Added bnrec patch
  173. * Tue Dec 29 1998 Jonathan Ruano <kobalt@james.encomix.es>
  174. - minimum spec and patches changes for openssl
  175. - modified for openssl sources
  176. * Sat Aug 8 1998 Khimenko Victor <khim@sch57.msk.ru>
  177. - shared library creating process honours $RPM_OPT_FLAGS
  178. - shared libarry supports threads (as well as static library)
  179. * Wed Jul 22 1998 Khimenko Victor <khim@sch57.msk.ru>
  180. - building of shared library completely reworked
  181. * Tue Jul 21 1998 Khimenko Victor <khim@sch57.msk.ru>
  182. - RPM is BuildRoot'ed
  183. * Tue Feb 10 1998 Khimenko Victor <khim@sch57.msk.ru>
  184. - all stuff is moved out of /usr/local