1
0

rules 477 B

12345678910111213141516171819202122
  1. #!/usr/bin/make -f
  2. #
  3. # Build Debian package using https://github.com/spotify/dh-virtualenv
  4. #
  5. override_dh_systemd_enable:
  6. dh_systemd_enable --name=matrix-synapse
  7. override_dh_installinit:
  8. dh_installinit --name=matrix-synapse
  9. override_dh_strip:
  10. override_dh_shlibdeps:
  11. override_dh_virtualenv:
  12. ./debian/build_virtualenv
  13. # We are restricted to compat level 9 (because xenial), so have to
  14. # enable the systemd bits manually.
  15. %:
  16. dh $@ --with python-virtualenv --with systemd