123456789101112131415161718192021222324252627282930313233343536 |
- #!/usr/bin/make -f
- #
- # Build Debian package using https://github.com/spotify/dh-virtualenv
- #
- # assume we only have one package
- PACKAGE_NAME:=`dh_listpackages`
- override_dh_systemd_enable:
- dh_systemd_enable --name=matrix-synapse
- override_dh_installinit:
- dh_installinit --name=matrix-synapse
- # we don't really want to strip the symbols from our object files.
- override_dh_strip:
- override_dh_shlibdeps:
- # make the postgres package's dependencies a recommendation
- # rather than a hard dependency.
- find debian/$(PACKAGE_NAME)/ -path '*/site-packages/psycopg2/*.so' | \
- xargs dpkg-shlibdeps -Tdebian/$(PACKAGE_NAME).substvars \
- -pshlibs1 -dRecommends
- # all the other dependencies can be normal 'Depends' requirements,
- # except for PIL's, which is self-contained and which confuses
- # dpkg-shlibdeps.
- dh_shlibdeps -X site-packages/PIL/.libs -X site-packages/psycopg2
- override_dh_virtualenv:
- ./debian/build_virtualenv
- # We are restricted to compat level 9 (because xenial), so have to
- # enable the systemd bits manually.
- %:
- dh $@ --with python-virtualenv --with systemd
|