1234567891011121314151617 |
- {
- description = "Synapse (development)";
- inputs = {
- utils.url = "github:numtide/flake-utils";
- };
- outputs = { self, nixpkgs, utils }:
- utils.lib.eachDefaultSystem (system: let
- pkgs = nixpkgs.legacyPackages."${system}";
- in rec {
- # `nix develop`
- devShell = pkgs.mkShell {
- nativeBuildInputs = with pkgs; [ rustc cargo python sqlite poetry postgresql icu clang ];
- };
- });
- }
|