#122 Downgrade

Open
opened 1 week ago by americadragons · 3 comments

Its posible via Lucy GUI make a dowgrade from 1.5a version to 1.49? mi router is tplink wr710n and in the las firmware version i have some problems whit the wifi range and other that in the previous version i didnt have.

Its posible via Lucy GUI make a dowgrade from 1.5a version to 1.49? mi router is tplink wr710n and in the las firmware version i have some problems whit the wifi range and other that in the previous version i didnt have.
RISCI_ATOM commented 1 week ago
Collaborator

mi router is tplink wr710n and in the las firmware version i have some problems whit the wifi range and other

Can you please provide the hardware version and which libreCMC image you flashed to the device? What other issues were you having with the device? Have you tried different channels?

Its posible via Lucy GUI make a dowgrade from 1.5a version to 1.49?

NOTE: This is possible and the following is provided for informational purposes. The libreCMC project is not responsible for bricked devices.

Everything is going to depend on which image you used and the hardware revision. v1.5.x and v1.4.9 are significantly different and improperly flashing could result in a brick. Luci will allow you to flash an older image by doing the following :

  1. Upload the v1.4.9 image like you normally would, but it is going to fail.

  2. After it fails, you will then be presented with a "Force Flash" checkbox. Make sure the "Force Flash" checkbox is checked and the "Keep Settings" checkbox is unchecked. Failure to do this will result in a brick.

  3. Upload the v1.4.9 image and click "Flash Image...".

  4. On the next page, confirm the image hash.

Please keep in mind that it's strongly advised to not downgrade to v1.4.9 because it has various security issues, some of which can be remotely exploited with normal usage.

> mi router is tplink wr710n and in the las firmware version i have some problems whit the wifi range and other Can you please provide the hardware version and which libreCMC image you flashed to the device? What other issues were you having with the device? Have you tried different channels? > Its posible via Lucy GUI make a dowgrade from 1.5a version to 1.49? *NOTE:* This is possible and the following is provided for informational purposes. The libreCMC project is *not* responsible for bricked devices. Everything is going to depend on which image you used and the hardware revision. `v1.5.x` and `v1.4.9` are significantly different and improperly flashing could result in a brick. Luci will allow you to flash an older image by doing the following : 1. Upload the `v1.4.9` image like you normally would, but it is going to fail. 2. After it fails, you will then be presented with a "Force Flash" checkbox. Make sure the "Force Flash" checkbox is checked and the "Keep Settings" checkbox is *unchecked*. Failure to do this will result in a brick. 3. Upload the `v1.4.9` image and click "Flash Image...". 4. On the next page, confirm the image hash. Please keep in mind that it's *strongly* advised to not downgrade to `v1.4.9` because it has various security issues, some of which can be remotely exploited with normal usage.
americadragons commented 1 week ago
Poster

Hardware version 1.2, it has rigth now 1.5.0a and y want to downgrade to 1.4.9 or 1.4.8 , 1.5.0 has estability issues drops wifi connections time to time and the wifi range its not the same despite the tx power its the same. i have tried to downgrade de 1.4.9 sysupgrade version but dosent recongnized the file has a valida file.

Hardware version 1.2, it has rigth now 1.5.0a and y want to downgrade to 1.4.9 or 1.4.8 , 1.5.0 has estability issues drops wifi connections time to time and the wifi range its not the same despite the tx power its the same. i have tried to downgrade de 1.4.9 sysupgrade version but dosent recongnized the file has a valida file.
americadragons commented 1 week ago
Poster
sorry i flashed the 1.4.9 sysupgrade version allmost 4 mb https://librecmc.org/librecmc/downloads/snapshots/v1.4.9/ar71xx/generic/librecmc-ar71xx-generic-tl-wr710n-v1-squashfs-sysupgrade.bin
Sign in to join this conversation.
Loading...
Cancel
Save
There is no content yet.