#146 opkg update failed to decode signature for ath79 generic packages

Closed
opened 1 year ago by dustfinger · 4 comments

Running opkg update results in a signature check failure for ath79 generic packages.

root@libreCMC:~# opkg update
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/targets/ath79/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/librecmc_core
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/targets/ath79/generic/packages/Packages.sig
Failed to decode signature
Signature check failed.
Remove wrong Signature file.
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/base/Packages.gz
Updated list of available packages in /var/opkg-lists/librecmc_base
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/base/Packages.sig
Signature check passed.
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/librecmc_packages
Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/packages/Packages.sig
Signature check passed.

Please advise.

Running opkg update results in a signature check failure for ath79 generic packages. ``` root@libreCMC:~# opkg update Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/targets/ath79/generic/packages/Packages.gz Updated list of available packages in /var/opkg-lists/librecmc_core Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/targets/ath79/generic/packages/Packages.sig Failed to decode signature Signature check failed. Remove wrong Signature file. Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/base/Packages.gz Updated list of available packages in /var/opkg-lists/librecmc_base Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/base/Packages.sig Signature check passed. Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/packages/Packages.gz Updated list of available packages in /var/opkg-lists/librecmc_packages Downloading https://librecmc.org/librecmc/downloads/snapshots/v1.5.5/packages/mips_24kc/packages/Packages.sig Signature check passed. ``` Please advise.
TMakarios commented 1 year ago

I think I had a similar problem, but it was solved by upgrading to v1.5.7.

I think I had a similar problem, but it was solved by upgrading to v1.5.7.
dustfinger commented 1 year ago
Poster

I just upgraded to v1.5.7. There are no packages to upgrade now, so I am not sure if the sigs validate or not. I could probably figure that out with opkg-key. Hopefully the sigs are all valid in the next round of updates. Someone should probably correct the sigs for v1.5.5 though, so that those whom have not yet upgraded will be able to run the upgrade command with confidence.

I just upgraded to v1.5.7. There are no packages to upgrade now, so I am not sure if the sigs validate or not. I could probably figure that out with opkg-key. Hopefully the sigs are all valid in the next round of updates. Someone should probably correct the sigs for v1.5.5 though, so that those whom have not yet upgraded will be able to run the upgrade command with confidence.
TMakarios commented 1 year ago

There are no packages to upgrade now, so I am not sure if the sigs validate or not.

When you run opkg update, you should get "Signature check passed" after each pair of downloads.

> There are no packages to upgrade now, so I am not sure if the sigs validate or not. When you run `opkg update`, you should get "Signature check passed" after each pair of downloads.
dustfinger commented 1 year ago
Poster

@TMakarios, you are correct. All sigs pass on v1.5.7 :-) I will close this issue.

@TMakarios, you are correct. All sigs pass on v1.5.7 :-) I will close this issue.
Sign in to join this conversation.
Loading...
Cancel
Save
There is no content yet.