#155 v1.5.11 is in git repository, but no release

Closed
opened 2 months ago by grizzlyuser · 3 comments

I saw there's a commit [1] for v1.5.11 in git, but there was no release in [2] and [3]. Does it mean there were no significant security fixes since v1.5.10, or there is an issue blocking the release?

What's the recommendation for now? For example:

  1. Wait for new release since there's no strong reason to upgrade now.
  2. Build v1.5.11 from source since there are important fixes.

[1] 74e2bc4686 [2] https://gogs.librecmc.org/libreCMC/libreCMC/releases [3] https://librecmc.org/librecmc/downloads/snapshots/

I saw there's a commit [1] for v1.5.11 in git, but there was no release in [2] and [3]. Does it mean there were no significant security fixes since v1.5.10, or there is an issue blocking the release? What's the recommendation for now? For example: 1. Wait for new release since there's no strong reason to upgrade now. 2. Build v1.5.11 from source since there are important fixes. [1] https://gogs.librecmc.org/libreCMC/libreCMC/commit/74e2bc46868d44ad7ea92cfdc7a433f7964632e6 [2] https://gogs.librecmc.org/libreCMC/libreCMC/releases [3] https://librecmc.org/librecmc/downloads/snapshots/
hugmenot commented 2 weeks ago

I can't recommend to build v.1.5.11 yet. Unless you're an experienced user. I'm not and will tell you about my first try which was yesterday:)

Build process as per build documentation runs flawlessly. Accept one constant warning:

WARNING: Makefile 'package/feeds/packages/aircrack-ng/Makefile' has a dependency on 'libhwloc', which does not exist

I think when this package isn't needed / selected, the warning can easily be ignored. The resulting imagesize for TL-1043v4 was 4.1MB. Well, previously builds from official libreCMC download for this device always were around 4.6MB. Either something fundamently changed (e.g. maybe a new compression method?) or some packages were missing. Turns out, the latter was the case.

Flashed via web UI, the upgrade process (with kept settings) runs smoothly, and the router booted straight up. But, there was no web UI... Login via ssh worked. Luci and some other packages I selected during menu config were missing and I can't tell why. 4.1MB huh?:) Also, opkg update wasn't possible. The feed mirrors obviously aren't available yet. So I changed them...

  • $ vi /etc/opkg/distfeeds.conf
  • Alter every 1.5.11 to 1.5.10

I know this isn't completely sane, but I was fun to grab some first experiences and play with OpenWRT / libreCMC. In the end it's always possible to go back to v.1.5.10.

So, with adjusted feed mirrors, opkg update finally worked, which made it possible to run opkg install luci luci-base without errors.

Well, there we are. With a working v1.5.11 and luci. Unfortunately some packages I definitely want to have aren't compatible yet. Like dnsmask-full. It complains about the kernel version.

In the end I took the chance to flash the old image again, so I'm back on v.1.5.10, with kept settings and some gained knowledge:)

I can't recommend to build v.1.5.11 yet. Unless you're an experienced user. I'm not and will tell you about my first try which was yesterday:) Build process as per [build documentation](https://librecmc.org/fossil/librecmc/wiki?name=How_To_Build_libreCMC) runs flawlessly. Accept one constant warning: WARNING: Makefile 'package/feeds/packages/aircrack-ng/Makefile' has a dependency on 'libhwloc', which does not exist I think when this package isn't needed / selected, the warning can easily be ignored. The resulting imagesize for TL-1043v4 was 4.1MB. Well, previously builds from official libreCMC download for this device always were around 4.6MB. Either something fundamently changed (e.g. maybe a new compression method?) or some packages were missing. Turns out, the latter was the case. Flashed via web UI, the upgrade process (with kept settings) runs smoothly, and the router booted straight up. But, there was no web UI... Login via ssh worked. Luci and some other packages I selected during `menu config` were missing and I can't tell why. 4.1MB huh?:) Also, `opkg update` wasn't possible. The feed mirrors obviously aren't available yet. So I changed them... - `$ vi /etc/opkg/distfeeds.conf` - Alter every `1.5.11` to `1.5.10` I know this isn't completely sane, but I was fun to grab some first experiences and play with OpenWRT / libreCMC. In the end it's always possible to go back to v.1.5.10. So, with adjusted feed mirrors, `opkg update` finally worked, which made it possible to run `opkg install luci luci-base` without errors. Well, there we are. With a working v1.5.11 and luci. Unfortunately some packages I definitely want to have aren't compatible yet. Like dnsmask-full. It complains about the kernel version. In the end I took the chance to flash the old image again, so I'm back on v.1.5.10, with kept settings and some gained knowledge:)
hugmenot commented 6 days ago

libreCMC v1.5.11 seems to have been skipped, in favour of v1.5.12 which just came out today.

If your preliminary questions can also be skipped due to this, you're welcome to close this issue.

libreCMC v1.5.11 seems to have been skipped, in favour of v1.5.12 which just came out today. If your preliminary questions can also be skipped due to this, you're welcome to close this issue.
grizzlyuser commented 6 days ago
Poster

Thanks for the update! Closed.

Thanks for the update! Closed.
Sign in to join this conversation.
Loading...
Cancel
Save
There is no content yet.