#4 Problems during make

Closed
opened 4 years ago by bkottke · 2 comments
bkottke commented 4 years ago

Having problems during the make. After configuring the settings i wanted with 'make menuconfig', once i try to build with 'make' it is throwing the following errors at me. I am not super familiar with make / make menuconfig yet (still learning), So this may just be something silly I am doing wrong.. But figured I would post just in case.

OS: Trisquel 7.0

$ make -j1 V=s

libtool: compile:  gcc -std=gnu99 -DPACKAGE_NAME=\"libressl\" -DPACKAGE_TARNAME=\"libressl\" -DPACKAGE_VERSION=\"2.5.0\" "-DPACKAGE_STRING=\"libressl 2.5.0\"" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"libressl\" -DVERSION=\"2.5.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_SYMLINK=1 -DHAVE_ERR_H=1 -DHAVE_ASPRINTF=1 -DHAVE_INET_PTON=1 -DHAVE_MEMMEM=1 -DHAVE_STRNDUP=1 -DHAVE_STRNLEN=1 -DHAVE_STRSEP=1 -DHAVE_TIMEGM=1 -DHAVE_ACCEPT4=1 -DHAVE_POLL=1 -DHAVE_GETAUXVAL=1 -DHAVE_VA_COPY=1 -DHAVE___VA_COPY=1 -DHAS_GNU_WARNING_LONG=1 -DSIZEOF_TIME_T=4 -I. -I../include -I../include/compat -DLIBRESSL_INTERNAL -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE -O2 -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include -fpic -Wall -std=gnu99 -fno-strict-aliasing -fno-strict-overflow -D_FORTIFY_SOURCE=2 -fstack-protector-all -DHAVE_GNU_STACK -Wno-pointer-sign -MT ssl_err.lo -MD -MP -MF .deps/ssl_err.Tpo -c ssl_err.c -o ssl_err.o
/usr/bin/env bash ../libtool  --tag=CC   --mode=link gcc -std=gnu99  -O2 -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include  -fpic -Wall -std=gnu99 -fno-strict-aliasing  -fno-strict-overflow -D_FORTIFY_SOURCE=2 -fstack-protector-all -DHAVE_GNU_STACK  -Wno-pointer-sign -version-info 39:1:0 -no-undefined -L/home/user/Documents/github/libreCMC/staging_dir/host/lib -L/home/user/Documents/github/libreCMC/staging_dir/host/usr/lib   -Wl,-z,relro -Wl,-z,now  -o libssl.la -rpath /home/user/Documents/github/libreCMC/staging_dir/host/lib bio_ssl.lo bs_ber.lo bs_cbb.lo bs_cbs.lo d1_both.lo d1_clnt.lo d1_enc.lo d1_lib.lo d1_meth.lo d1_pkt.lo d1_srtp.lo d1_srvr.lo pqueue.lo s23_clnt.lo s23_lib.lo s23_pkt.lo s23_srvr.lo s3_both.lo s3_cbc.lo s3_clnt.lo s3_lib.lo s3_pkt.lo s3_srvr.lo ssl_algs.lo ssl_asn1.lo ssl_cert.lo ssl_ciph.lo ssl_err.lo ssl_err2.lo ssl_lib.lo ssl_rsa.lo ssl_sess.lo ssl_stat.lo ssl_txt.lo t1_clnt.lo t1_enc.lo t1_lib.lo t1_meth.lo t1_reneg.lo t1_srvr.lo /home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/crypto/libcrypto.la -lresolv 
libtool: link: `ssl_err2.lo' is not a valid libtool object
make[5]: *** [libssl.la] Error 1
make[5]: Leaving directory `/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/ssl'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0'
make[3]: *** [/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/.built] Error 2
make[3]: Leaving directory `/home/user/Documents/github/libreCMC/tools/libressl'
make[2]: *** [tools/libressl/compile] Error 2
make[2]: Leaving directory `/home/user/Documents/github/libreCMC'
make[1]: *** [/home/user/Documents/github/libreCMC/staging_dir/target-mips_24kc_musl-1.1.15/stamp/.tools_install_yyyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynnny] Error 2
make[1]: Leaving directory `/home/user/Documents/github/libreCMC'
make: *** [world] Error 2
Having problems during the make. After configuring the settings i wanted with 'make menuconfig', once i try to build with 'make' it is throwing the following errors at me. I am not super familiar with make / make menuconfig yet (still learning), So this may just be something silly I am doing wrong.. But figured I would post just in case. OS: Trisquel 7.0 $ make -j1 V=s ``` libtool: compile: gcc -std=gnu99 -DPACKAGE_NAME=\"libressl\" -DPACKAGE_TARNAME=\"libressl\" -DPACKAGE_VERSION=\"2.5.0\" "-DPACKAGE_STRING=\"libressl 2.5.0\"" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"libressl\" -DVERSION=\"2.5.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_SYMLINK=1 -DHAVE_ERR_H=1 -DHAVE_ASPRINTF=1 -DHAVE_INET_PTON=1 -DHAVE_MEMMEM=1 -DHAVE_STRNDUP=1 -DHAVE_STRNLEN=1 -DHAVE_STRSEP=1 -DHAVE_TIMEGM=1 -DHAVE_ACCEPT4=1 -DHAVE_POLL=1 -DHAVE_GETAUXVAL=1 -DHAVE_VA_COPY=1 -DHAVE___VA_COPY=1 -DHAS_GNU_WARNING_LONG=1 -DSIZEOF_TIME_T=4 -I. -I../include -I../include/compat -DLIBRESSL_INTERNAL -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_SOURCE -D_GNU_SOURCE -O2 -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include -fpic -Wall -std=gnu99 -fno-strict-aliasing -fno-strict-overflow -D_FORTIFY_SOURCE=2 -fstack-protector-all -DHAVE_GNU_STACK -Wno-pointer-sign -MT ssl_err.lo -MD -MP -MF .deps/ssl_err.Tpo -c ssl_err.c -o ssl_err.o /usr/bin/env bash ../libtool --tag=CC --mode=link gcc -std=gnu99 -O2 -I/home/user/Documents/github/libreCMC/staging_dir/host/include -I/home/user/Documents/github/libreCMC/staging_dir/host/usr/include -fpic -Wall -std=gnu99 -fno-strict-aliasing -fno-strict-overflow -D_FORTIFY_SOURCE=2 -fstack-protector-all -DHAVE_GNU_STACK -Wno-pointer-sign -version-info 39:1:0 -no-undefined -L/home/user/Documents/github/libreCMC/staging_dir/host/lib -L/home/user/Documents/github/libreCMC/staging_dir/host/usr/lib -Wl,-z,relro -Wl,-z,now -o libssl.la -rpath /home/user/Documents/github/libreCMC/staging_dir/host/lib bio_ssl.lo bs_ber.lo bs_cbb.lo bs_cbs.lo d1_both.lo d1_clnt.lo d1_enc.lo d1_lib.lo d1_meth.lo d1_pkt.lo d1_srtp.lo d1_srvr.lo pqueue.lo s23_clnt.lo s23_lib.lo s23_pkt.lo s23_srvr.lo s3_both.lo s3_cbc.lo s3_clnt.lo s3_lib.lo s3_pkt.lo s3_srvr.lo ssl_algs.lo ssl_asn1.lo ssl_cert.lo ssl_ciph.lo ssl_err.lo ssl_err2.lo ssl_lib.lo ssl_rsa.lo ssl_sess.lo ssl_stat.lo ssl_txt.lo t1_clnt.lo t1_enc.lo t1_lib.lo t1_meth.lo t1_reneg.lo t1_srvr.lo /home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/crypto/libcrypto.la -lresolv libtool: link: `ssl_err2.lo' is not a valid libtool object make[5]: *** [libssl.la] Error 1 make[5]: Leaving directory `/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/ssl' make[4]: *** [all-recursive] Error 1 make[4]: Leaving directory `/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0' make[3]: *** [/home/user/Documents/github/libreCMC/build_dir/host/libressl-2.5.0/.built] Error 2 make[3]: Leaving directory `/home/user/Documents/github/libreCMC/tools/libressl' make[2]: *** [tools/libressl/compile] Error 2 make[2]: Leaving directory `/home/user/Documents/github/libreCMC' make[1]: *** [/home/user/Documents/github/libreCMC/staging_dir/target-mips_24kc_musl-1.1.15/stamp/.tools_install_yyyyyyynyyyyynyynnyyyyyyyyyyyyyyyyyyyynyynynyyyynnny] Error 2 make[1]: Leaving directory `/home/user/Documents/github/libreCMC' make: *** [world] Error 2 ```
bkottke commented 4 years ago
Poster

Forgot to give router info.

Router: TP-Link TL-WDR3600 v1.5

I know it is not officially supported. But would be willing to attempt a flash if i could get it to compile. Could also provide feedback on any bugs / errors along the way.

-B

Forgot to give router info. Router: TP-Link TL-WDR3600 v1.5 I know it is not officially supported. But would be willing to attempt a flash if i could get it to compile. Could also provide feedback on any bugs / errors along the way. -B
RISCI_ATOM commented 4 years ago
Collaborator

I was not able to reproduce this error on a clean install of Trisquel 7 with the dependencies listed in the Build HOWTO. A different issue was encountered where the linux-libre kernel we pull from upstream was removed. To fix this issue, make sure to run git pull against your checked out version of the libreCMC repository and run the build again.

I was not able to reproduce this error on a clean install of Trisquel 7 with the dependencies listed in the [Build HOWTO](/wiki/How-To-Build-libreCMC). A different issue was encountered where the linux-libre kernel we pull from upstream was removed. To fix this issue, make sure to run `git pull` against your checked out version of the libreCMC repository and run the build again.
Sign in to join this conversation.
Loading...
Cancel
Save
There is no content yet.