#6 [TL-MR3020]: opkg - unable to install or update anything from official repositories

Closed
opened 6 years ago by Polarus · 5 comments
Polarus commented 6 years ago
root@librecmc:~# opkg update
Downloading https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz
wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz

Downloading https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz
wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz

Downloading https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz
wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages.
*** Failed to download the package list from https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz

Collected errors:
 * opkg_download: Failed to download https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz, wget returned 1.
 * opkg_download: Failed to download https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz, wget returned 1.

After changing URIs from https to http in /etc/opkg/distfeeds.conf the following can be observed:

root@librecmc:~# opkg update
Downloading http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz
*** Failed to download the package list from http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz

Downloading http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz
*** Failed to download the package list from http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz

Downloading http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz
*** Failed to download the package list from http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz

Collected errors:
 * opkg_download: Failed to download http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz, wget returned 8.
 * opkg_download: Failed to download http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz, wget returned 8.
 * opkg_download: Failed to download http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz, wget returned 8.

Tried also without ':80'. There really is no easy way to get any package or to update repositories - I think it is nessesary to include all required packages and certificates or provide non-expert users with ability to download everything via traditional unencrypted http connection, as I don't know way to pass --no-check-certificate to wget using opkg.

Image used: https://librecmc.org/librecmc/downloads/snapshots/v1.4-core/ar71xx/generic/librecmc-ar71xx-generic-tl-mr3020-v1-squashfs-sysupgrade.bin

``` root@librecmc:~# opkg update Downloading https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages. *** Failed to download the package list from https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz Downloading https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages. *** Failed to download the package list from https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz Downloading https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz wget: SSL support not available, please install one of the libustream-ssl-* libraries as well as the ca-bundle and ca-certificates packages. *** Failed to download the package list from https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz Collected errors: * opkg_download: Failed to download https://librecmc.org/librecmc/targets/ar71xx/generic/packages/Packages.gz, wget returned 1. * opkg_download: Failed to download https://librecmc.org/librecmc/packages/mips_24kc/base/Packages.gz, wget returned 1. * opkg_download: Failed to download https://librecmc.org/librecmc/packages/mips_24kc/packages/Packages.gz, wget returned 1. ``` After changing URIs from https to http in /etc/opkg/distfeeds.conf the following can be observed: ``` root@librecmc:~# opkg update Downloading http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz *** Failed to download the package list from http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz Downloading http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz *** Failed to download the package list from http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz Downloading http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz *** Failed to download the package list from http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz Collected errors: * opkg_download: Failed to download http://librecmc.org:80/librecmc/targets/ar71xx/generic/packages/Packages.gz, wget returned 8. * opkg_download: Failed to download http://librecmc.org:80/librecmc/packages/mips_24kc/base/Packages.gz, wget returned 8. * opkg_download: Failed to download http://librecmc.org:80/librecmc/packages/mips_24kc/packages/Packages.gz, wget returned 8. ``` Tried also without ':80'. There really is no easy way to get any package or to update repositories - I think it is nessesary to include all required packages and certificates or provide non-expert users with ability to download everything via traditional unencrypted http connection, as I don't know way to pass `--no-check-certificate` to wget using opkg. Image used: https://librecmc.org/librecmc/downloads/snapshots/v1.4-core/ar71xx/generic/librecmc-ar71xx-generic-tl-mr3020-v1-squashfs-sysupgrade.bin
RISCI_ATOM commented 6 years ago
Collaborator

This bug is partially fixed. v1.4-core images were compiled without some dependencies. All v1.4-core images have been recompiled and the issue will be fixed in v1.4.1.

This bug is partially fixed. v1.4-core images were compiled without some dependencies. All v1.4-core images have been recompiled and the issue will be fixed in v1.4.1.
Polarus commented 6 years ago
Poster

Ok,but now no TL-3020 image at all. Is this intentional?

Ok,but now no TL-3020 image at all. Is this intentional?
Ghost commented 6 months ago

I was not able to install it and I needed it a lot I came here and found a way to install it so I am giving the tip of this Chuckys Tiffany Valentine Black Jacket to the person who shared it.

I was not able to install it and I needed it a lot I came here and found a way to install it so I am giving the tip of this <a href="https://www.hitjacket.com/product/chuckys-tiffany-valentine-black-jacket/">Chuckys Tiffany Valentine Black Jacket</a> to the person who shared it.
Ghost commented 5 months ago

A portion of the bug has been fixed. Images for v1.4-core were assembled without certain dependencies. After recompiling all v1.4-core images, the problem will be resolved in v1.4.1. build now gg

A portion of the bug has been fixed. Images for v1.4-core were assembled without certain dependencies. After recompiling all v1.4-core images, the problem will be resolved in v1.4.1. <a href="https://buildnowgg.io">build now gg</a>
Ghost commented 4 months ago

It seems you're facing difficulties with opkg installation or updates from official repositories. To bypass SSL verification, try modifying the opkg.conf file with "option check_signature 0." However, note that this poses security risks. For non-expert users, consider a pre-packaged solution. In other news, exploring benefits of technology like the Apple Watch Series 7 ($399) could enhance daily life, offering features like health tracking and notifications for a more connected experience.

<p>It seems you're facing difficulties with opkg installation or updates from official repositories. To bypass SSL verification, try modifying the opkg.conf file with "option check_signature 0." However, note that this poses security risks. For non-expert users, consider a pre-packaged solution. In other news, exploring <a href="https://brainwavetrail.com/cryotherapy-treatment-how-much-does-it-cost/">benefits</a> of technology like the <a href="https://answersrepublic.com/health/best-smartwatch-for-diabetics/">Apple Watch Series 7 ($399)</a> could enhance daily life, offering features like health tracking and notifications for a more connected experience.</p>
Sign in to join this conversation.
Loading...
Cancel
Save
There is no content yet.